Album  

No power

 
Post new topic   Reply to topic    Home  /  RumbleBee.org - The Dodge Ram Rumble Bee Owner Community Forum Index -> Technical discussion
View previous topic :: View next topic  
Author Message
TrboBee


Colonel Sanders


Joined: 25 Sep 2005
Posts: 6343
Gallery pictures: 27
TrboBee's gallery
Location: Vancouver, BC

PostPosted: Mon Apr 23, 2018 1:58 pm    Post subject: No power Reply with quote

Wow its been a long time since logging on! hopefully there is still someone out there to hear this message!

So my bee over the past couple years has become a part time vehicle. slowly being driven less and less until last winter the battery died. charged, died, charged, died, etc... it was an old battery but everything was still fine though.

Got a new battery recently. everything was great. didnt drive again for about a month since the weather was terrible and the new battery died. I took it out, charged it up, the bee tried cranking a few times and then nothing.

Now no power is going to anything in the bee. no lights, radio, anything. even with a full and new battery. check all the fuses and all looks fine. The only thing ive seen any power going to since this is the little red "security light" on the dash, but when i try turning the key in the ignition it goes off and everything is dead.

Has anyone out there seen a similar situation or has any thoughts as to why my be is K.O.?

I dont really want to just give it to the dealer and tell them to go to town investigating. im sure they would rack up a monster bill for me in no time.

_________________
Anthony - If you cant beat em, join em...and then beat em!

3051 Second Swarm 4X4

Current Mods:
SRT10 Hood, Bed Rug, Black headlights, Undercover tonneau, BFI Intake, Superchips Tuner, Dynatech LT header system, 2.5" straight duals with Flow pro Max mufflers, 2/4 drop with air assist bags, 4.56 & DTT, EDGE 2600

Performance:
0-60: 5.57 Seconds in 4hi (old time)

Still For Sale: 4X4 Dynatech headers w/ stub shafts. perfect for a kick ass dual exhaust set up. pm me for details
Back to top
View user's profile Send private message  
booky
Seasoned Veteran




Joined: 02 Feb 2006
Posts: 1569
Gallery pictures: 59
booky's gallery
Location: Van Wert, OH

PostPosted: Wed May 09, 2018 4:07 am    Post subject: Reply with quote

Are you saying that you are on your Second completely New battery?

If not, the first thing I would do is go and get a Different New battery, hook it up and see if the same thing happens.

Sometimes new batteries have defects too and you could have got a bad one. I would not trust testing the battery or recharging it, I would try a completely Different New battery first, before anything else.

Keep us updated.

_________________
>>Greg<<
2005 DAYTONA 4x4 #08876
Dynatech Supermaxx Headers w/ Cherry Bomb Extreme - AEM Brute Force CAI
Superchips Flashpaq Tuner-Performance Level
3" Body Lift Kit w/ Nitto 35's
.
2016 Dodge Challenger Hellcat
Red Key(707 HP)+A8 Auto+3.09 Gears+DR's
.
2012 Shelby GT500 (sold)
2003 Mustang Cobra (sold)
Back to top
View user's profile Send private message Send e-mail  
abitwar10
Seasoned Veteran




Joined: 10 Jun 2005
Posts: 4224
Gallery pictures: 54
abitwar10's gallery
Location: Oak Lawn, IL

PostPosted: Tue May 15, 2018 1:04 pm    Post subject: Reply with quote

I too barely drive the truck, but I regularly keep it on a trickle charger. I had a similar issue to you, but a new battery corrected it. Weird that you're still having the issue with a new battery. If you've only had the new battery a month or so, you should be able to return it as defective and get a new replacement. As stated above, try that first before spending money to diagnose if it is something else. Best of luck!
_________________
Ken

2003 Harley Davidson Vrod (Black)
Second Swarm 4x4 #4266 (Yellow)

K&N drop-in, Truxedo low profile tonneau, AT3030, Bed Rug, Honeycomb Ram floor mats, stripe extensions, custom pedals, Honeycomb Grille, SRT wing, MRK accents, custom etched Chrome fuel door, '06 Chrome Ram Wheels, Infinity reference components powered by Pioneer, JL 10w6v2 in a HotBox powered by JL Audio
Back to top
View user's profile Send private message Send e-mail AIM Address
abitwar10
Seasoned Veteran




Joined: 10 Jun 2005
Posts: 4224
Gallery pictures: 54
abitwar10's gallery
Location: Oak Lawn, IL

PostPosted: Tue May 15, 2018 1:08 pm    Post subject: Reply with quote

...also, not sure if you have a stereo system, but check that your amps aren't drawing power after the ignition is turned off.
_________________
Ken

2003 Harley Davidson Vrod (Black)
Second Swarm 4x4 #4266 (Yellow)

K&N drop-in, Truxedo low profile tonneau, AT3030, Bed Rug, Honeycomb Ram floor mats, stripe extensions, custom pedals, Honeycomb Grille, SRT wing, MRK accents, custom etched Chrome fuel door, '06 Chrome Ram Wheels, Infinity reference components powered by Pioneer, JL 10w6v2 in a HotBox powered by JL Audio
Back to top
View user's profile Send private message Send e-mail AIM Address
Display posts from previous:   
Post new topic   Reply to topic    Home  /  RumbleBee.org - The Dodge Ram Rumble Bee Owner Community Forum Index :: Technical discussion All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum




Powered by phpBB © 2004 phpBB Group
Charcoal2 Theme © Zarron Media